× A place for general chat about the Jimny. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Suppliers/Dealers or anyone selling with a commercial view in mind CANNOT post here unless responding to a specific request of a member in a "wanted" post.

Suppliers include people "breaking for spares" on a regular basis, when purchasing spares members should ask a supplier what they contribute to the running of the forum particularly if contacted by a Private Message

Suppliers or Members who have contributed to the forum can be identifed by the
logo.[/size][/color][/b]

Speedo sensor needed

More
21 Oct 2020 10:06 #229337 by stoneuk
Speedo sensor needed was created by stoneuk
Hi, Can anyone help me please .. I've been told i need a speedo sensor that is located on the gearbox . I have 1.3 Jimny 2002 auto . Thanks
Attachments:

Please Log in or Create an account to join the conversation.

More
21 Oct 2020 16:07 #229350 by X8GGY
Replied by X8GGY on topic Speedo sensor needed
Hi... it's on the transfer box, not the gearbox..

Martin (this is his discussion board and store) can probably get you a new one, or a breaker (on eBay?) could supply a second-hand one...?

What's wrong with yours?...

Wandered off for a bit... you'll find me in the garage building a Jimny Buggy ;)

Please Log in or Create an account to join the conversation.

More
21 Oct 2020 16:13 - 21 Oct 2020 16:13 #229351 by mlines
Replied by mlines on topic Speedo sensor needed
I guess the price is the reason Steven is asking here - its £165 for a new one I quoted this morning

I would check the wiring first at that is what normally fails.

Interestingly enough, Suzuki have a different part numbers for the sensor fitted to Autos and Manuals (despite it fitting to the transfer case) so I am not sure you could use one from a manual car.

Martin

2003 M13 early KAP build.
3" Trailmaster lift with 1.5 Spacers on front
Customised winch bumper and roll cage
235/85R16 Maxxis Bighorns on 16" Rims, 4:1 Rocklobster, Rear ARB locker and on-board air
Corrected arms all-round, rear disks, Recaro seats and harnesses
Last edit: 21 Oct 2020 16:13 by mlines.
The following user(s) said Thank You: stoneuk

Please Log in or Create an account to join the conversation.

More
22 Oct 2020 11:14 #229391 by stoneuk
Replied by stoneuk on topic Speedo sensor needed
Hi, Thanks for getting back to me .. He electrical guy said he "Thinks" it's the problem as to why i've not any movement on the speedo .. (The odometer is working fine)
I'll be honest and say that a second hand one would be the best bet as a new one could work out expensive if it's not cured afterwards .. Thanks

Please Log in or Create an account to join the conversation.

More
23 Oct 2020 20:58 #229439 by kirkynut
Replied by kirkynut on topic Speedo sensor needed

stoneuk wrote: Hi, Thanks for getting back to me .. He electrical guy said he "Thinks" it's the problem as to why i've not any movement on the speedo .. (The odometer is working fine)
I'll be honest and say that a second hand one would be the best bet as a new one could work out expensive if it's not cured afterwards .. Thanks


I disagree with the electrical guy as how can the odometer be working if the sensor isn't? My old 2000 model has no abs, so the only thing counting revolutions of anything speed wise is that sensor. It therefore has to feed the odometer and speedo.

I'd suggest that the issue is in the speedo itself or the wiring to it.

Kirkynut

The underdog often starts the fight, and occasionally the upper dog deserves to win - Edgar Watson Howe.

My Jimny Thread Here: www.bigjimny.com/index.php/forum/8-my-ji...on-continues?start=0

Please Log in or Create an account to join the conversation.

More
24 Oct 2020 13:00 #229452 by jackonlyjack
Replied by jackonlyjack on topic Speedo sensor needed
I have to agree with Kirky
When i first fiited my sj box sensor wasn't sat correct and no miles where being added
Speedo needle used to jump around
But when it was showing speed miles where adding

I have a spare sensor somewhere from a manual

Please Log in or Create an account to join the conversation.

More
24 Oct 2020 19:51 #229472 by j999pre
Replied by j999pre on topic Speedo sensor needed
Just found this so sorry if sorted.

Disconnect the battery for 15 minutes then reconnect.

50% of the time this will fix it for free

Gold Jimny the best colour (sold) :(

Big red Jimny 32" tyres, arbs, cage 5:1 transfer etc. (Sold)

Grey pick up Jimny
Turbo m13a, arbs, floating rear shafts, disc conversion rear, vented front conversion. 245 70 16. Winch, 3" lift, 4:16 trans hd shafts and CVS

Please Log in or Create an account to join the conversation.

More
26 Oct 2020 21:08 #229490 by kirkynut
Replied by kirkynut on topic Speedo sensor needed

j999pre wrote: Just found this so sorry if sorted.

Disconnect the battery for 15 minutes then reconnect.

50% of the time this will fix it for free


Now you've said this I remember someone posting this in the past.

Apologies for not remembering it before.

Kirkynut

The underdog often starts the fight, and occasionally the upper dog deserves to win - Edgar Watson Howe.

My Jimny Thread Here: www.bigjimny.com/index.php/forum/8-my-ji...on-continues?start=0

Please Log in or Create an account to join the conversation.

Time to create page: 0.753 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.

We use cookies to give you the best online experience. Please let us know if you agree to all of these cookies. Accepting the Cookies also accepts the Disclaimers for the website.